using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)\s*:\s*(.*?)\s*(?=(?:\w+\s*:)|$)";
string input = @"name: phil age : 23 range: 33, 45 address: ""main ave US""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}