$re = '/(\w+)\s*:\s*(.*?)\s*(?=(?:\w+\s*:)|$)/';
$str = 'name: phil age : 23 range: 33, 45 address: "main ave US"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);