re = /(\w+)\s*:\s*(.*?)\s*(?=(?:\w+\s*:)|$)/
str = 'name: phil age : 23 range: 33, 45 address: "main ave US"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end