const regex = new RegExp('(\\w+)\\s*:\\s*(.*?)\\s*(?=(?:\\w+\\s*:)|$)', 'g')
const str = `name: phil age : 23 range: 33, 45 address: "main ave US"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}