using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(A\d{1,8}|B|C|D|E|F|G|J|K|L|M|N|P|Q|R|S|T|U|H|V|W|Y|ZR)\b";
string input = @"225/75 R17.5 128/126М М470 Trans-Steel Semperit";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}