re = /\b(A\d{1,8}|B|C|D|E|F|G|J|K|L|M|N|P|Q|R|S|T|U|H|V|W|Y|ZR)\b/
str = '225/75 R17.5 128/126М М470 Trans-Steel Semperit'
# Print the match result
str.match(re) do |match|
puts match.to_s
end