use strict;
my $str = '225/75 R17.5 128/126М М470 Trans-Steel Semperit';
my $regex = qr/\b(A\d{1,8}|B|C|D|E|F|G|J|K|L|M|N|P|Q|R|S|T|U|H|V|W|Y|ZR)\b/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}