package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(A\d{1,8}|B|C|D|E|F|G|J|K|L|M|N|P|Q|R|S|T|U|H|V|W|Y|ZR)\b`)
var str = `225/75 R17.5 128/126М М470 Trans-Steel Semperit`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}