using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(mul)\((\d+),(\d+)\)|(do)\(\)|(don't)\(\)";
string input = @"xmul(2,4)&mul[3,7]!^don't()_mul(5,5)+mul(32,64](mul(11,8)undo()?mul(8,5))";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}