package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(mul)\((\d+),(\d+)\)|(do)\(\)|(don't)\(\)`)
var str = `xmul(2,4)&mul[3,7]!^don't()_mul(5,5)+mul(32,64](mul(11,8)undo()?mul(8,5))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}