$re = '/(mul)\((\d+),(\d+)\)|(do)\(\)|(don\'t)\(\)/m';
$str = 'xmul(2,4)&mul[3,7]!^don\'t()_mul(5,5)+mul(32,64](mul(11,8)undo()?mul(8,5))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);