#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^msgid ""\r?\n([\s\S]*?)\r?\n(?=^msgstr ""\r?\n?)"
Local $sString = "#: apps/catalogue/abstract_models.py:206" & @CRLF & _
"msgid """ & @CRLF & _
""Universal Product Code (UPC) is an identifier for a product which is not "" & @CRLF & _
""specific to a particular supplier. Eg an ISBN for a book."" & @CRLF & _
"msgstr """ & @CRLF & _
"" & @CRLF & _
"#: apps/catalogue/abstract_models.py:213" & @CRLF & _
"#: templates/oscar/dashboard/catalogue/product_list.html:87" & @CRLF & _
"#: templates/oscar/dashboard/catalogue/product_update.html:168" & @CRLF & _
"#: templates/oscar/dashboard/catalogue/product_update.html:190" & @CRLF & _
"msgid "Parent"" & @CRLF & _
"msgstr "والد"" & @CRLF & _
"" & @CRLF & _
"#: apps/catalogue/abstract_models.py:214" & @CRLF & _
"msgid """ & @CRLF & _
""Only choose a parent product if this is a 'variant' of a canonical "" & @CRLF & _
""catalogue. For example if this is a size 4 of a particular t-shirt. Leave "" & @CRLF & _
""blank if this is a CANONICAL PRODUCT (ie there is only one version of this "" & @CRLF & _
""product)."" & @CRLF & _
"msgstr """
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")