import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^msgid \"\"\\r?\\n([\\s\\S]*?)\\r?\\n(?=^msgstr \"\"\\r?\\n?)";
final String string = "#: apps/catalogue/abstract_models.py:206\n"
+ "msgid \"\"\n"
+ "\"Universal Product Code (UPC) is an identifier for a product which is not \"\n"
+ "\"specific to a particular supplier. Eg an ISBN for a book.\"\n"
+ "msgstr \"\"\n\n"
+ "#: apps/catalogue/abstract_models.py:213\n"
+ "#: templates/oscar/dashboard/catalogue/product_list.html:87\n"
+ "#: templates/oscar/dashboard/catalogue/product_update.html:168\n"
+ "#: templates/oscar/dashboard/catalogue/product_update.html:190\n"
+ "msgid \"Parent\"\n"
+ "msgstr \"والد\"\n\n"
+ "#: apps/catalogue/abstract_models.py:214\n"
+ "msgid \"\"\n"
+ "\"Only choose a parent product if this is a 'variant' of a canonical \"\n"
+ "\"catalogue. For example if this is a size 4 of a particular t-shirt. Leave \"\n"
+ "\"blank if this is a CANONICAL PRODUCT (ie there is only one version of this \"\n"
+ "\"product).\"\n"
+ "msgstr \"\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}