use strict;
my $str = '#: apps/catalogue/abstract_models.py:206
msgid ""
"Universal Product Code (UPC) is an identifier for a product which is not "
"specific to a particular supplier. Eg an ISBN for a book."
msgstr ""
#: apps/catalogue/abstract_models.py:213
#: templates/oscar/dashboard/catalogue/product_list.html:87
#: templates/oscar/dashboard/catalogue/product_update.html:168
#: templates/oscar/dashboard/catalogue/product_update.html:190
msgid "Parent"
msgstr "والد"
#: apps/catalogue/abstract_models.py:214
msgid ""
"Only choose a parent product if this is a \'variant\' of a canonical "
"catalogue. For example if this is a size 4 of a particular t-shirt. Leave "
"blank if this is a CANONICAL PRODUCT (ie there is only one version of this "
"product)."
msgstr ""';
my $regex = qr/^msgid ""\r?\n([\s\S]*?)\r?\n(?=^msgstr ""\r?\n?)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}