using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^msgid ""\r?\n([\s\S]*?)\r?\n(?=^msgstr ""\r?\n?)";
string input = @"#: apps/catalogue/abstract_models.py:206
msgid ""
""Universal Product Code (UPC) is an identifier for a product which is not ""
""specific to a particular supplier. Eg an ISBN for a book.""
msgstr ""
#: apps/catalogue/abstract_models.py:213
#: templates/oscar/dashboard/catalogue/product_list.html:87
#: templates/oscar/dashboard/catalogue/product_update.html:168
#: templates/oscar/dashboard/catalogue/product_update.html:190
msgid ""Parent""
msgstr ""والد""
#: apps/catalogue/abstract_models.py:214
msgid ""
""Only choose a parent product if this is a 'variant' of a canonical ""
""catalogue. For example if this is a size 4 of a particular t-shirt. Leave ""
""blank if this is a CANONICAL PRODUCT (ie there is only one version of this ""
""product).""
msgstr """;
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}