# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(((apple|mango|banana)\s*)+) is (\d+)kg$/$1,$4/gm;t' <<< "apple is 2kg
apple banana mango is 2kg
apple apple apple is 6kg
banana banana banana is 6kg"