const regex = /^(((apple|mango|banana)\s*)+) is (\d+)kg$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((apple|mango|banana)\\s*)+) is (\\d+)kg$', 'gm')
const str = `apple is 2kg
apple banana mango is 2kg
apple apple apple is 6kg
banana banana banana is 6kg`;
const subst = `$1,$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);