#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(((apple|mango|banana)\s*)+) is (\d+)kg$"
Local $sString = "apple is 2kg" & @CRLF & _
"apple banana mango is 2kg" & @CRLF & _
"apple apple apple is 6kg" & @CRLF & _
"banana banana banana is 6kg"
Local $sSubst = "$1,$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)