package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(((apple|mango|banana)\s*)+) is (\d+)kg$`)
var str = `apple is 2kg
apple banana mango is 2kg
apple apple apple is 6kg
banana banana banana is 6kg`
var substitution = "$1,$4"
fmt.Println(re.ReplaceAllString(str, substitution))
}