# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/{%\ (if)[\s\S]*?{%\ end\1\ %}|
{%.+?%}|
{{.+?}}//gx;t' <<< "<div class=\"post-preview\">
<div class=\"post-title\">
<div class=\"post-name\">
<a href=\"{{ post.url }}\">{{ post.title }}</a>
</div>
<div class=\"post-date\">
{% include time.html %}
</div>
</div>
<div class=\"post-snippet\">
{% if post.content contains '<!--break-->' %}
{{ post.content | split:'<!--break-->' | first }}
<div class=\"post-readmore\">
<a href=\"{{ post.url }}\">read more-></a>
</div>
{% endif %}
</div>
{% include post-meta.html %}
</div>"