import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{%\\ (if)[\\s\\S]*?\\{%\\ end\\1\\ %\\}|\n"
+ "\\{%.+?%\\}|\n"
+ "\\{\\{.+?\\}\\}";
final String string = "<div class=\"post-preview\">\n"
+ " <div class=\"post-title\">\n"
+ " <div class=\"post-name\">\n"
+ " <a href=\"{{ post.url }}\">{{ post.title }}</a>\n"
+ " </div>\n"
+ " <div class=\"post-date\">\n"
+ " {% include time.html %}\n"
+ " </div>\n"
+ " </div>\n\n"
+ " <div class=\"post-snippet\">\n"
+ " {% if post.content contains '<!--break-->' %}\n"
+ " {{ post.content | split:'<!--break-->' | first }}\n"
+ " <div class=\"post-readmore\">\n"
+ " <a href=\"{{ post.url }}\">read more-></a>\n"
+ " </div>\n"
+ " {% endif %}\n"
+ " </div>\n"
+ " {% include post-meta.html %}\n"
+ "</div>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}