#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sx)(?P<content>.*?) # Content up to next tag" & @CRLF & _
"(?P<markup> # Entire tag" & @CRLF & _
" <!\[CDATA\[(?P<cdata>.+?)]]>| # <![CDATA[ ... ]]>" & @CRLF & _
" <!--(?P<comment>.+?)-->| # <!-- Comment -->" & @CRLF & _
" </\s*(?P<close_tag>\w+)\s*>| # </tag>" & @CRLF & _
" <(?P<tag>\w+) # <tag ..." & @CRLF & _
" (?P<attributes>" & @CRLF & _
" (?P<attribute>\s+" & @CRLF & _
"# <snip>: Use this part to get the attributes out of 'attributes' group." & @CRLF & _
" (?P<attribute_name>\w+)" & @CRLF & _
" (?:\s*=\s*" & @CRLF & _
" (?P<attribute_value>" & @CRLF & _
" [\w:/.\-]+| # Unquoted" & @CRLF & _
" (?=(?P<_v> # Quoted" & @CRLF & _
" (?P<_q>['\"]).*?(?<!\\)(?P=_q)))" & @CRLF & _
" (?P=_v)" & @CRLF & _
" ))?" & @CRLF & _
"# </snip>" & @CRLF & _
" )*" & @CRLF & _
" )\s*" & @CRLF & _
" (?P<is_self_closing>/?) # Self-closing indicator" & @CRLF & _
" >) # End of tag" & @CRLF & _
""
Local $sString = "In this case, $url will indeed contain http://example.com/whatever.jpg. But what happens when you start getting HTML like this:" & @CRLF & _
"" & @CRLF & _
"<img src='http://example.com/whatever.jpg'>" & @CRLF & _
"or" & @CRLF & _
"" & @CRLF & _
"<img src=http://example.com/whatever.jpg>" & @CRLF & _
"or" & @CRLF & _
"" & @CRLF & _
"<img border=0 src="http://example.com/whatever.jpg">" & @CRLF & _
"or" & @CRLF & _
"" & @CRLF & _
"<img border src="http://example.com/whatever.jpg">" & @CRLF & _
"or" & @CRLF & _
"" & @CRLF & _
"<img" & @CRLF & _
" src="http://example.com/whatever.jpg">" & @CRLF & _
"or you start getting false positives from" & @CRLF & _
"" & @CRLF & _
"<!-- // commented out" & @CRLF & _
"<img src="http://example.com/outdated.png">" & @CRLF & _
"-->" & @CRLF & _
"" & @CRLF & _
"<script><![CDATA[ This is <b>not</b> parsed ]]></script>" & @CRLF & _
"" & @CRLF & _
"<asd ASD=asd>" & @CRLF & _
"" & @CRLF & _
"<!-- // commented out <img src="http://example.com/outdated.png"> -->" & @CRLF & _
"" & @CRLF & _
"No quotes:" & @CRLF & _
"<iframe src=test.html target=xyz></ iframe >" & @CRLF & _
"Self-closing tag:" & @CRLF & _
"<a href=test.html target=xyz/>" & @CRLF & _
"Self closing tag with a space before closure:" & @CRLF & _
"<a href=test.html target=xyz />" & @CRLF & _
"Double quotes:" & @CRLF & _
"<a href="test.html" target="xyz">" & @CRLF & _
"Single quotes:" & @CRLF & _
"<a href='test.html' target='xyz'>" & @CRLF & _
"Escaping double quotes:" & @CRLF & _
"<a href="test.html?val=1" title="\"No rules exist\" Andre Breton's quote">" & @CRLF & _
"Escaping single quotes (also with spaces between equals signs):" & @CRLF & _
"<a href = "test.html?val=1" title = 'Charlie\'s Angels'>" & @CRLF & _
"Tag without closure (ignored):" & @CRLF & _
"<a href = "test.html?val=1" title='Charlie\'s Angels'" & @CRLF & _
"Tag without opening (ignored):" & @CRLF & _
"a href = "test.html?val=1" title="Charlie\"s Angels">" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")