import re
regex = re.compile(r"""
(?P<content>.*?) # Content up to next tag
(?P<markup> # Entire tag
<!\[CDATA\[(?P<cdata>.+?)]]>| # <![CDATA[ ... ]]>
<!--(?P<comment>.+?)-->| # <!-- Comment -->
</\s*(?P<close_tag>\w+)\s*>| # </tag>
<(?P<tag>\w+) # <tag ...
(?P<attributes>
(?P<attribute>\s+
# <snip>: Use this part to get the attributes out of 'attributes' group.
(?P<attribute_name>\w+)
(?:\s*=\s*
(?P<attribute_value>
[\w:/.\-]+| # Unquoted
(?=(?P<_v> # Quoted
(?P<_q>['\"]).*?(?<!\\)(?P=_q)))
(?P=_v)
))?
# </snip>
)*
)\s*
(?P<is_self_closing>/?) # Self-closing indicator
>) # End of tag
""", flags=re.DOTALL | re.VERBOSE)
test_str = ("In this case, $url will indeed contain http://example.com/whatever.jpg. But what happens when you start getting HTML like this:\n\n"
"<img src='http://example.com/whatever.jpg'>\n"
"or\n\n"
"<img src=http://example.com/whatever.jpg>\n"
"or\n\n"
"<img border=0 src=\"http://example.com/whatever.jpg\">\n"
"or\n\n"
"<img border src=\"http://example.com/whatever.jpg\">\n"
"or\n\n"
"<img\n"
" src=\"http://example.com/whatever.jpg\">\n"
"or you start getting false positives from\n\n"
"<!-- // commented out\n"
"<img src=\"http://example.com/outdated.png\">\n"
"-->\n\n"
"<script><![CDATA[ This is <b>not</b> parsed ]]></script>\n\n"
"<asd ASD=asd>\n\n"
"<!-- // commented out <img src=\"http://example.com/outdated.png\"> -->\n\n"
"No quotes:\n"
"<iframe src=test.html target=xyz></ iframe >\n"
"Self-closing tag:\n"
"<a href=test.html target=xyz/>\n"
"Self closing tag with a space before closure:\n"
"<a href=test.html target=xyz />\n"
"Double quotes:\n"
"<a href=\"test.html\" target=\"xyz\">\n"
"Single quotes:\n"
"<a href='test.html' target='xyz'>\n"
"Escaping double quotes:\n"
"<a href=\"test.html?val=1\" title=\"\\\"No rules exist\\\" Andre Breton's quote\">\n"
"Escaping single quotes (also with spaces between equals signs):\n"
"<a href = \"test.html?val=1\" title = 'Charlie\\'s Angels'>\n"
"Tag without closure (ignored):\n"
"<a href = \"test.html?val=1\" title='Charlie\\'s Angels'\n"
"Tag without opening (ignored):\n"
"a href = \"test.html?val=1\" title=\"Charlie\\\"s Angels\">\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")