using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<content>.*?) # Content up to next tag
(?P<markup> # Entire tag
<!\[CDATA\[(?P<cdata>.+?)]]>| # <![CDATA[ ... ]]>
<!--(?P<comment>.+?)-->| # <!-- Comment -->
</\s*(?P<close_tag>\w+)\s*>| # </tag>
<(?P<tag>\w+) # <tag ...
(?P<attributes>
(?P<attribute>\s+
# <snip>: Use this part to get the attributes out of 'attributes' group.
(?P<attribute_name>\w+)
(?:\s*=\s*
(?P<attribute_value>
[\w:/.\-]+| # Unquoted
(?=(?P<_v> # Quoted
(?P<_q>['\""]).*?(?<!\\)(?P=_q)))
(?P=_v)
))?
# </snip>
)*
)\s*
(?P<is_self_closing>/?) # Self-closing indicator
>) # End of tag
";
string input = @"In this case, $url will indeed contain http://example.com/whatever.jpg. But what happens when you start getting HTML like this:
<img src='http://example.com/whatever.jpg'>
or
<img src=http://example.com/whatever.jpg>
or
<img border=0 src=""http://example.com/whatever.jpg"">
or
<img border src=""http://example.com/whatever.jpg"">
or
<img
src=""http://example.com/whatever.jpg"">
or you start getting false positives from
<!-- // commented out
<img src=""http://example.com/outdated.png"">
-->
<script><![CDATA[ This is <b>not</b> parsed ]]></script>
<asd ASD=asd>
<!-- // commented out <img src=""http://example.com/outdated.png""> -->
No quotes:
<iframe src=test.html target=xyz></ iframe >
Self-closing tag:
<a href=test.html target=xyz/>
Self closing tag with a space before closure:
<a href=test.html target=xyz />
Double quotes:
<a href=""test.html"" target=""xyz"">
Single quotes:
<a href='test.html' target='xyz'>
Escaping double quotes:
<a href=""test.html?val=1"" title=""\""No rules exist\"" Andre Breton's quote"">
Escaping single quotes (also with spaces between equals signs):
<a href = ""test.html?val=1"" title = 'Charlie\'s Angels'>
Tag without closure (ignored):
<a href = ""test.html?val=1"" title='Charlie\'s Angels'
Tag without opening (ignored):
a href = ""test.html?val=1"" title=""Charlie\""s Angels"">
";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}