#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)attrs={(.+?):\s*(.+?)}"
Local $sString = "this.mk(attrs={keyCollection.key: 40}))" & @CRLF & _
"this.mk(attrs={keyCollection.key: 50, override.key: override.value})" & @CRLF & _
"this.mk(attrs={keyCollection.key: 60, " & @CRLF & _
" override.key: override.value})"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")