import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "attrs=\\{(.+?):\\s*(.+?)\\}";
final String string = "this.mk(attrs={keyCollection.key: 40}))\n"
+ "this.mk(attrs={keyCollection.key: 50, override.key: override.value})\n"
+ "this.mk(attrs={keyCollection.key: 60, \n"
+ " override.key: override.value})";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}