package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)attrs={(.+?):\s*(.+?)}`)
var str = `this.mk(attrs={keyCollection.key: 40}))
this.mk(attrs={keyCollection.key: 50, override.key: override.value})
this.mk(attrs={keyCollection.key: 60,
override.key: override.value})`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}