#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-zA-Z0-9:._\$]+(?=\$)"
Local $sString = "> str(datasets::iris$)" & @CRLF & _
"> plot(datasets::iris$" & @CRLF & _
"str(datasets::iris$)" & @CRLF & _
"plot(datasets::iris$" & @CRLF & _
"str(iris$)" & @CRLF & _
"plot(iris$" & @CRLF & _
"plot(BOD$" & @CRLF & _
"iris$" & @CRLF & _
"A$" & @CRLF & _
"A$a2$" & @CRLF & _
"A$a2$b3$" & @CRLF & _
"a.b$" & @CRLF & _
"a_b$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")