$re = '/[a-zA-Z0-9:._\$]+(?=\$)/m';
$str = '> str(datasets::iris$)
> plot(datasets::iris$
str(datasets::iris$)
plot(datasets::iris$
str(iris$)
plot(iris$
plot(BOD$
iris$
A$
A$a2$
A$a2$b3$
a.b$
a_b$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);