using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-zA-Z0-9:._\$]+(?=\$)";
string input = @"> str(datasets::iris$)
> plot(datasets::iris$
str(datasets::iris$)
plot(datasets::iris$
str(iris$)
plot(iris$
plot(BOD$
iris$
A$
A$a2$
A$a2$b3$
a.b$
a_b$";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}