re = /[a-zA-Z0-9:._\$]+(?=\$)/m
str = '> str(datasets::iris$)
> plot(datasets::iris$
str(datasets::iris$)
plot(datasets::iris$
str(iris$)
plot(iris$
plot(BOD$
iris$
A$
A$a2$
A$a2$b3$
a.b$
a_b$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end