import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|[^'\\u00C0-\\u1FFF\\u2C00-\\uD7FF\\w])([\\u00C0-\\u1FFF\\u2C00-\\uD7FF\\w])(?![^(]*\\))";
final String string = "I can't (do) this, please (help) me.\n\n"
+ "I am (someone) ვიღაც\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}