re = /(?:^|[^'\u00C0-\u1FFF\u2C00-\uD7FF\w])([\u00C0-\u1FFF\u2C00-\uD7FF\w])(?![^(]*\))/
str = 'I can\'t (do) this, please (help) me.
I am (someone) ვიღაც
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end