const regex = /(?:^|[^'\u00C0-\u1FFF\u2C00-\uD7FF\w])([\u00C0-\u1FFF\u2C00-\uD7FF\w])(?![^(]*\))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|[^\'\\u00C0-\\u1FFF\\u2C00-\\uD7FF\\w])([\\u00C0-\\u1FFF\\u2C00-\\uD7FF\\w])(?![^(]*\\))', 'g')
const str = `I can't (do) this, please (help) me.
I am (someone) ვიღაც
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}