$re = '/(?:^|[^\'\u00C0-\u1FFF\u2C00-\uD7FF\w])([\u00C0-\u1FFF\u2C00-\uD7FF\w])(?![^(]*\))/';
$str = 'I can\'t (do) this, please (help) me.
I am (someone) ვიღაც
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);