import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "dip=\\\"[^\\\"]*\\\"([ ]dp=\\\"[^\\\"]*\\\")[ ]nat-dip=\\\"([^\\\"]*)\\\"";
final String string = "sip=\"100.107.0.5\" sp=\"123\" dip=\"100.107.193.1\" dp=\"123\" nat-dip=\"84.2.44.19\" sip=\"100.101.199.1\" sp=\"37690\" dip=\"100.107.0.4\" dp=\"80\" nat-dip=\"100.107.0.4\"";
final String subst = "dip=\"\\2\"\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}