const regex = new RegExp('dip=\\"[^\\"]*\\"([ ]dp=\\"[^\\"]*\\")[ ]nat-dip=\\"([^\\"]*)\\"', 'g')
const str = `sip="100.107.0.5" sp="123" dip="100.107.193.1" dp="123" nat-dip="84.2.44.19" sip="100.101.199.1" sp="37690" dip="100.107.0.4" dp="80" nat-dip="100.107.0.4"`;
const subst = `dip="\2"\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);