import re
regex = re.compile(r"dip=\"[^\"]*\"([ ]dp=\"[^\"]*\")[ ]nat-dip=\"([^\"]*)\"")
test_str = "sip=\"100.107.0.5\" sp=\"123\" dip=\"100.107.193.1\" dp=\"123\" nat-dip=\"84.2.44.19\" sip=\"100.101.199.1\" sp=\"37690\" dip=\"100.107.0.4\" dp=\"80\" nat-dip=\"100.107.0.4\""
subst = "dip=\"\\2\"\\1"
result = regex.sub(subst, test_str)
if result:
print(result)