// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"dip=\"[^\"]*\"([ ]dp=\"[^\"]*\")[ ]nat-dip=\"([^\"]*)\""#).unwrap();
let string = "sip=\"100.107.0.5\" sp=\"123\" dip=\"100.107.193.1\" dp=\"123\" nat-dip=\"84.2.44.19\" sip=\"100.101.199.1\" sp=\"37690\" dip=\"100.107.0.4\" dp=\"80\" nat-dip=\"100.107.0.4\"";
let substitution = "dip=\"\\2\"\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}