#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(\[([\0-\\\^-\uFFFF]*)?\]\(([ \.-:A-Za-z]+)("(.+)")?\))"
Local $sString = "[test](http://google.com "hello")" & @CRLF & _
"[test](https://google.com "hello")" & @CRLF & _
"[test](google.com)" & @CRLF & _
"[](google.com)" & @CRLF & _
"[test](google.com "hello")" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")