const regex = /^(\[([\0-\\\^-\uFFFF]*)?\]\(([ \.-:A-Za-z]+)("(.+)")?\))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\[([\\0-\\\\\\^-\\uFFFF]*)?\\]\\(([ \\.-:A-Za-z]+)("(.+)")?\\))', '')
const str = `[test](http://google.com "hello")
[test](https://google.com "hello")
[test](google.com)
[](google.com)
[test](google.com "hello")
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}