$re = '/^(\[([\0-\\\\\^-\uFFFF]*)?\]\(([ \.-:A-Za-z]+)("(.+)")?\))/';
$str = '[test](http://google.com "hello")
[test](https://google.com "hello")
[test](google.com)
[](google.com)
[test](google.com "hello")
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);