import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\[([\\0-\\\\\\^-\\uFFFF]*)?\\]\\(([ \\.-:A-Za-z]+)(\"(.+)\")?\\))";
final String string = "[test](http://google.com \"hello\")\n"
+ "[test](https://google.com \"hello\")\n"
+ "[test](google.com)\n"
+ "[](google.com)\n"
+ "[test](google.com \"hello\")\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}