using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Are you sure you want to save\? \(y\/n\) ";
string input = @"Are you sure you want to save? (y/n) ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}