re = /Are you sure you want to save\? \(y\/n\) /
str = 'Are you sure you want to save? (y/n) '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end