$re = '/Are you sure you want to save\? \(y\/n\) /';
$str = 'Are you sure you want to save? (y/n) ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);