package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Are you sure you want to save\? \(y\/n\) `)
var str = `Are you sure you want to save? (y/n) `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}