#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<a (?:(?!</a>).)*mailicon4\.gif.*?</a>"
Local $sString = " <a href='abc'>blah blah</a>" & @CRLF & _
" <a class="nonblock nontext" id="u209382" href="mailto:info@example.com">" & @CRLF & _
" <!-- rasterized frame --><img class="temp_no_img_src" id="u209382_img" alt="" width="66" height="66"" & @CRLF & _
" data-orig-src="images/mailicon4-u209382.png?crc=143036675" src="images/mailicon4.gif?crc=4208392903" /></a>" & @CRLF & _
" <a href='abc'>blah blah</a>" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")