re = /<a (?:(?!<\/a>).)*mailicon4\.gif.*?<\/a>/
str = ' <a href=\'abc\'>blah blah</a>
<a class="nonblock nontext" id="u209382" href="mailto:info@example.com">
<!-- rasterized frame --><img class="temp_no_img_src" id="u209382_img" alt="" width="66" height="66"
data-orig-src="images/mailicon4-u209382.png?crc=143036675" src="images/mailicon4.gif?crc=4208392903" /></a>
<a href=\'abc\'>blah blah</a>
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end