import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a (?:(?!</a>).)*mailicon4\\.gif.*?</a>";
final String string = " <a href='abc'>blah blah</a>\n"
+ " <a class=\"nonblock nontext\" id=\"u209382\" href=\"mailto:info@example.com\">\n"
+ " <!-- rasterized frame --><img class=\"temp_no_img_src\" id=\"u209382_img\" alt=\"\" width=\"66\" height=\"66\"\n"
+ " data-orig-src=\"images/mailicon4-u209382.png?crc=143036675\" src=\"images/mailicon4.gif?crc=4208392903\" /></a>\n"
+ " <a href='abc'>blah blah</a>\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}